Telstra - Mobiles - Outage

Incident Report for PCONNECT

Resolved

Telstra has advised that the issue should be resolved.
Posted Jul 08, 2026 - 09:57 AEST

Identified

Telstra is currently experiencing a large-scale mobile network outage affecting voice and data services nationally, with some users seeing "SOS only" on their phones. Reports started coming in from around 5am AEST and are affecting NSW, QLD, VIC, and TAS.

The outage isn't limited to Telstra's own customers, it's also impacting MVNOs running on the Telstra network (Pconnect Mobile, Belong, Boost, Mate, etc). Impact appears uneven, with some services affected and others on the same network unaffected.

Telstra has acknowledged the issue on social media, stating only "some" mobile calls and data connections are affected, and recommends toggling airplane mode on/off to force your phone to reconnect.

No official cause or ETA has been given yet. We'll share updates as they come through.
Posted Jul 08, 2026 - 07:48 AEST
This incident affected: CELLULAR (Telstra Wholesale).