Upstream Provider - Nationwide Network Issues

Incident Report for PConnect

Resolved

We have received an update confirming that the issue was isolated to TPG networks, which experienced connectivity problems with specific cloud services due to traffic routing within the TPG network. The issue should now be resolved.
Posted Mar 23, 2026 - 10:31 AEDT

Investigating

We are currently receiving reports of a nationwide network issue affecting some services. Our team has escalated this with our upstream provider and is awaiting further updates.

This issue is impacting Fibre and NBN connections. We will provide additional information as soon as it becomes available.
Posted Mar 20, 2026 - 13:25 AEDT
This incident affected: PCONNECT Internet.